CivicPlus Meets Early TLS Compliance Requirements

Written by Deb McNew

New requirements associated with the Payment Card Industry (PCI) Data Security Standard (DSS) state that all payment systems must disable early Transport Layer Security (TLS) by 2018. TLS is a technology used to encrypt sensitive information sent via the Internet. TLS is the replacement for Secure Sockets Layer (SSL).

In preparation for this requirement, CivicPlus® plans to disable early TLS (1.0 and TLS 1.1) on August 19, 2017. This change means that we will no longer support the Internet Explorer (IE) version 10 browser.

CivicPlus clients that currently utilize IE10 across their administration will need to upgrade to IE11, or to another compliant browser, in order to support the new, required TLS 1.2 level. 

We recognize that browser support is a key concern to many clients. CivicPlus browser support is predicated on ensuring that our clients and their citizens have the best experiences possible with our CivicEngage® websites, while ensuring the security of information and reliability of our software.

CivicPlus supports the current version of most major browsers, however if manufacturers choose to terminate their support for a product or version, CivicPlus is no longer able support that solution in our development or testing environments either.

Please contact your internal IT staff to ensure that your browser can support the latest TLS 1.2 requirement. Note that browsers released prior to 2014 may not support TLS 1.2. You can check your browser's TLS support capabilities by visiting How’s My SSL?

For more information regarding TLS compliance, please refer to the chart below:

Desktop Browsers Currently Supported by CivicEngage
  Internet Explorer Microsoft Edge Firefox Google Chrome Apple Safari
PC V4: IE11

V5: IE11
V4: Latest Version

V5: Latest Version
V4: Latest Version 

V5: Latest Version
V4: Latest Version

V5: Latest Version
V4: Not Supported

V5: Not Supported
Mac Not Supported Not Supported Not Supported Not Supported Latest Version

 

Mobile Browsers Currently Supported by CivicEngage® (front-end only)
  Native Browser Only
iOS Latest + 1 Previous
Android™ Latest + 1 Previous

 For more information, or if you have any questions, please contact our CivicPlus support specialists.